In this post we explain how to enable router interfaces to receive and forward frames with 802.1Q VLAN tags on Cisco, Juniper and Alcatel-Lucent
Cisco DOT1Q
Interface Configuration:
In cisco to enable 802.1Q encapsulation on a subinterface, use the encapsulation dot1q command.
Cisco-RTR#sh run interface gigabitEthernet 2/2/20.10-
Building configuration...
Current configuration : 95 bytes
!
interface GigabitEthernet1/9
encapsulation dot1Q 100
ip address 10.10.10.1 255.255.255.252
end
Juniper DOT1Q
Interface Configuration:
In Juniper routers to configure the interface to receive and forward frames with 802.1Q VLAN tags, include the vlan-tagging statement.
In Set format
set interfaces ge-2/2/20
vlan-tagging
set interfaces ge-2/2/20
unit 100 vlan-id 100
set interfaces ge-2/2/20 unit 1010 family inet address 10.10.10.1/30
lab@Juniper> show configuration interfaces ge-2/2/20
vlan-tagging
unit 100 {
vlan-id 100 ;
family inet {
address 10.10.10.1/30;
}
}
Alcatel-Lucent DOT1Q Interface configuration:
Alcatel-Lucent 7750 SR router ports must be configured as either access, hybrid or network. The default is network.
· Access ports — Customer facing ports on which services are configured
· Network ports —Network facing ports.
· Hybrid ports — Configured for access and network facing traffic.
Configuring interface in Alcatel is different when compared with Juniper and Cisco. Interface is completely logical entity in Alcatel-Lucent.
In Alcatel-Lucent
routers to configure the interface to receive and forward frames with 802.1Q
VLAN tags, include encap-type dot1q statement under port
configuration.
Configure Port Properties:
ALU-RTR# configure port 2/2/20 ethernet mtu 1500
ALU-RTR# configure port 2/2/20 ethernet encap-type dot1q
ALU-RTR# configure port 2/2/20 no shutdown
To view configuration on port go into configure port 2/2/20 hierarchy and enter info
ALU-RTR>config>port# info
----------------------------------------------
ethernet
encap-type dot1q
mtu 1500
exit
no shutdown
----------------------------------------------
ALU-RTR>config>port#
Interface Configuration:
For interface we have to give the name .To configure Interface with vlan-id 100 enter following commands:
ALU-RTR# configure router interface <INTERFACE-NAME> address 10.10.10.1/30
ALU-RTR# configure router interface
<INTERFACE-NAME> port 2/2/20:100
ALU-RTR# configure router interface <INTERFACE-NAME> no shutdown
To view configuration on interface go into configure router interface <INTERFACE-NAME> hierarchy and enter info
100 in “port 2/2/20:100” specifies vlan 100
ALU-RTR>config>router>if# info
---------------------------------------------
address 10.10.10.1/30
port 2/2/20:100
no shutdown
----------------------------------------------
ALU-RTR>config>router>if#
very helpful
ReplyDelete