In this post we demonstrate how to configure vlan based
Ethernet over MPLS on Cisco, Juniper and Alcatel-Lucent.
EoMPLS is called l2circuit on Juniper and Ethernet Pipe
(Epipe) on Alcatel-Lucent.
Prerequisites:
MPLS and ldp enabled throughout the network.
Topology:
In this example we have 3 sites and from each site we created
two L2 Circuits one each to remote sites.
On CPEs we have made 2 logical interfaces one each to remote
site.
Cisco-PE configuration:
interface
GigabitEthernet2/28.51
description "xconnect to juniper-PE"
encapsulation
dot1Q 51
xconnect
100.64.0.4 6010 encapsulation mpls
!
interface
GigabitEthernet2/28.52
description "xconnect to Alcatel-PE"
encapsulation
dot1Q 52
xconnect 100.64.0.102 6012 encapsulation mpls
!
Cisco-PE#
sh mpls l2transport vc 6010 detail
Local
interface: Gi2/28.51 up, line protocol up, Eth VLAN 51 up
Destination address: 100.64.0.4, VC ID: 6010,
VC status: up
Output interface: Gi8/1/3, imposed label
stack {0 480445}
Preferred path: not configured
Default path: active
Next hop: 172.31.22.25
Create time: 23:54:07, last status change
time: 21:15:09
Signaling protocol: LDP, peer 100.64.0.4:0 up
Targeted Hello:
100.64.0.6(LDP Id) -> 100.64.0.4
Status TLV support (local/remote) : enabled/not supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no
fault
Last local SSS circuit status sent: no
fault
Last local
LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: not sent
MPLS VC labels: local 20005, remote 480445
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Remote VLAN id: 51
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1012, send 1014
byte totals: receive 123032, send 119112
packet drops: receive 0, seq error 0, send 0
Cisco-PE#
Cisco-PE#sh
mpls l2transport vc 6012 detail
Local
interface: Gi2/28.52 up, line protocol up, Eth VLAN 52 up
Destination address: 100.64.0.102, VC ID:
6012, VC status: up
Output interface: Gi8/1/0, imposed label
stack {261325}
Preferred path: not configured
Default path: active
Next hop: 172.31.22.42
Create time: 00:54:13, last status change
time: 00:51:08
Signaling protocol: LDP, peer 100.64.0.102:0
up
Targeted Hello: 100.64.0.6(LDP Id) ->
100.64.0.102
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no
fault
Last local SSS circuit status sent: no
fault
Last local LDP TLV
status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 19266, remote 261325
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 2041, send 1006
byte totals: receive 197148, send 118600
packet drops: receive 0, seq error 0, send 0
Cisco-PE#
Site-1 CPE Configuration:
CPE-1#sh
run interface fastEthernet 0/0.51
Building
configuration...
Current
configuration : 97 bytes
!
interface
FastEthernet0/0.51
encapsulation dot1Q 51
ip address 172.16.1.1 255.255.255.0
end
CPE-1#sh
run interface fastEthernet 0/0.52
Building
configuration...
Current
configuration : 97 bytes
!
interface
FastEthernet0/0.52
encapsulation dot1Q 52
ip address 172.16.2.1 255.255.255.0
end
CPE-1#
//Reachability to Site-2:
CPE-1#ping
172.16.1.2
Type escape
sequence to abort.
Sending 5,
100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
//Reachability to Site-3:
CPE-1#ping
172.16.2.2
Type escape
sequence to abort.
Sending 5,
100-byte ICMP Echos to 172.16.2.2, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Juniper Configuration:
Jpr-PE> show
configuration interfaces ge-2/1/3
flexible-vlan-tagging;
encapsulation
flexible-ethernet-services;
unit 51 {
description "Xconnect to
Cisco-PE";
encapsulation vlan-ccc;
vlan-id 51;
}
unit 53 {
description "Xconnect to
Alcatel-PE";
encapsulation vlan-ccc;
vlan-id 53;
}
Jpr-PE>
show configuration protocols l2circuit
neighbor
100.64.0.6 {
interface ge-2/1/3.51 {
virtual-circuit-id 6010;
}
}
neighbor
100.64.0.102 {
interface ge-2/1/3.53 {
virtual-circuit-id 6013;
}
}
Verification:
Jpr-PE>
show l2circuit connections
Layer-2
Circuit Connections:
Legend for
connection status (St)
EI --
encapsulation invalid NP --
interface h/w not present
MM -- mtu
mismatch Dn -- down
EM --
encapsulation mismatch VC-Dn --
Virtual circuit Down
CM --
control-word mismatch Up --
operational
VM -- vlan
id mismatch CF -- Call
admission control failure
OL -- no
outgoing label IB -- TDM
incompatible bitrate
NC -- intf
encaps not CCC/TCC TM -- TDM
misconfiguration
BK --
Backup Connection ST -- Standby
Connection
CB -- rcvd
cell-bundle size bad SP -- Static
Pseudowire
LD -- local
site signaled down RS -- remote site
standby
RD -- remote
site signaled down HS -- Hot-standby
Connection
XX --
unknown
Legend for
interface status
Up --
operational
Dn --
down
Neighbor:
100.64.0.6
Interface Type St
Time last up # Up trans
ge-2/1/3.51(vc 6010) rmt
Up Aug 11 12:44:32 2016 1
Remote PE: 100.64.0.6, Negotiated
control-word: No
Incoming label: 480445, Outgoing label:
20005
Negotiated PW status TLV: No
Local interface: ge-2/1/3.51, Status: Up,
Encapsulation: VLAN
Flow Label Transmit: No, Flow Label
Receive: No
Neighbor:
100.64.0.102
Interface Type St
Time last up # Up trans
ge-2/1/3.53(vc 6013) rmt
Up Aug 11 10:27:05 2016 1
Remote PE: 100.64.0.102, Negotiated
control-word: No
Incoming label: 682032, Outgoing label:
261318
Negotiated PW status TLV: No
Local interface: ge-2/1/3.53, Status: Up,
Encapsulation: VLAN
Flow Label Transmit: No, Flow Label
Receive: No
Site-2 CPE Configuration:
CPE-2#sh
run interface GigabitEthernet0/0.50
Building
configuration...
Current
configuration : 100 bytes
!
interface
GigabitEthernet0/0.50
encapsulation dot1Q 51
ip address 172.16.1.2 255.255.255.0
end
CPE-2#sh
run interface GigabitEthernet0/0.53
Building
configuration...
Current
configuration : 100 bytes
!
interface
GigabitEthernet0/0.53
encapsulation dot1Q 53
ip address 172.16.3.1 255.255.255.0
end
//Ping CPE at
Site-1
CPE-2#ping
172.16.1.1
Type escape
sequence to abort.
Sending 5,
100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 4/12/20 ms
//Ping CPE at
Site-3
CPE-2#ping
172.16.3.2
Type escape
sequence to abort.
Sending 5,
100-byte ICMP Echos to 172.16.3.2, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
CPE-2#
Alcatel Configuration:
In Alcatel-lucent Ethernet Pipe (EPIPE) is
a layer 2 point-to-point service where the customer data is encapsulated and
transported across a service provider’s IP or MPLS network. EPIPE service is
based on the IETF “Martini Drafts”.
ALU-PE#configure
service customer 6010174 create
ALU-PE>config>service>cust#
description "epipe-alu-cisco-juniper"
ALU-PE>config>service>cust#
exit
ALU-PE#
configure service sdp 3005 mpls create
ALU-PE>config>service>sdp#
info
----------------------------------------------
description "SDP Towards
Cisco-PE"
far-end 100.64.0.6
ldp
path-mtu 1514
keep-alive
shutdown
exit
no shutdown
----------------------------------------------
ALU-PE>config>service>sdp#exit
ALU-PE#
configure service sdp 3006 mpls create
ALU-PE>config>service>sdp#
info
----------------------------------------------
description "SDP Towards
Juniper-PE"
far-end 100.64.0.4
ldp
path-mtu 1514
keep-alive
shutdown
exit
no shutdown
----------------------------------------------
ALU-PE>config>service>sdp#
ALU-PE#
configure service epipe 6012 customer 6010174 create
ALU-PE>config>service>epipe#
info
----------------------------------------------
description "Epipe towards
Cisco-PE"
sap 7/1/5:52 create
exit
spoke-sdp 3005:6012 vc-type vlan
create
no shutdown
exit
no shutdown----------------------------------------------
ALU-PE>config>service>epipe#exit
ALU-PE#
ALU-PE#
configure service epipe 30 customer 6010174 create
ALU-PE>config>service>epipe#
info
----------------------------------------------
description "Epipe towards Juniper-PE"
sap 7/1/5:53 create
exit
spoke-sdp 3006:6013 vc-type vlan
create
no shutdown
exit
no shutdown
----------------------------------------------
ALU-PE>config>service>epipe#
Verification on ALU-PE:
ALU-PE# show service sdp-using 3005:6012
===============================================================================
Service Destination Point (Sdp Id
: 3005:6012)
===============================================================================
SvcId SdpId Type Far End Opr I.Label
E.Label
State
-------------------------------------------------------------------------------
6012
3005:6012 Spok
100.64.0.6 Up 261325
19266
-------------------------------------------------------------------------------
Number of SDPs : 1
-------------------------------------------------------------------------------
===============================================================================
ALU-PE#
ALU-PE# show service sdp-using 3006:6013
===============================================================================
Service Destination Point (Sdp Id
: 3006:6013)
===============================================================================
SvcId SdpId Type Far End Opr I.Label
E.Label
State
-------------------------------------------------------------------------------
30
3006:6013 Spok
100.64.0.4 Up 261318
682032
-------------------------------------------------------------------------------
Number of SDPs : 1
-------------------------------------------------------------------------------
===============================================================================
ALU-PE#
ALU-PE# show service service-using sdp 3006
===============================================================================
Services Using SDP 3006
===============================================================================
ServiceId Type Adm
Opr CustomerId Service Name
-------------------------------------------------------------------------------
30 Epipe Up
Up 6010174
-------------------------------------------------------------------------------
Matching Services : 1
-------------------------------------------------------------------------------
===============================================================================
ALU-PE# show service service-using sdp 3005
===============================================================================
Services Using SDP 3005
===============================================================================
ServiceId Type Adm
Opr CustomerId Service Name
-------------------------------------------------------------------------------
6012 Epipe Up
Up 6010174
-------------------------------------------------------------------------------
Matching Services : 1
-------------------------------------------------------------------------------
===============================================================================
ALU-PE#
ALU-PE# show service service-using epipe customer 6010174
===============================================================================
Services [epipe]
Customer 6010174
===============================================================================
ServiceId Type Adm
Opr CustomerId Service Name
-------------------------------------------------------------------------------
30 Epipe Up
Up 6010174
6012 Epipe Up
Up 6010174
-------------------------------------------------------------------------------
Matching Services : 2
-------------------------------------------------------------------------------
===============================================================================
ALU-PE#
Customer Site-3
Configuration:
CPE-3#sh run interface fastEthernet 0/0.52
Building configuration...
Current configuration : 123 bytes
!
interface FastEthernet0/0.52
encapsulation dot1Q 52
ip address 172.16.2.2
255.255.255.0
end
CPE-3#sh run interface fastEthernet 0/0.53
Building configuration...
Current configuration : 123 bytes
!
interface FastEthernet0/0.53
encapsulation dot1Q 53
ip address 172.16.3.2
255.255.255.0
end
Verification:
//Site-1 reachability
CPE-3#ping 172.16.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2
seconds:
.!!!!
CPE-3#
//Site-2 reachability
CPE-3#ping 172.16.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2
seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms